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Preface 

Thank you for choosing FLM-ANT to protect your network. Using FLM-ANT, you 

will reap the benefits of an advanced detection mechanism designed to identify and 

manage threats to the Host Protected Network. 

Scope and Intended Audience 

This user guide offers operational information for users of FLM-ANT, a product for the 

creation and management of Access Control Lists (ACLôs).  The FLM-ANT User Guide 

serves as a reference for network system administrators who will be installing, configuring 

FLM-ANT, and using the system to monitor network traffic.  Users of the system are 

expected to be network system administrators with a working knowledge of the network 

infrastructure. 

Getting Help and Technical Support 

Technical assistance is available for users of FLM-ANT by contacting: 

 

 

 

 

 

Documentation Conventions 

The following general conventions and visual cues are used throughout this guide identify 

various fields, buttons, commands, and operations used within FLM-ANT. 

1. Button names, menu options, items, and commands that are to be typed into fields or 

at the command line are printed in boldface type; for example, ñClick Remove to 

delete the file from the database.ò 

2.  File names and directories are shown in boldface courier font; for example 
/etc/rc.conf .  

3. Notes are enclosed in boxes as shown below.  

 

 
 

 

 

 

 

Notes call particular attention to a step or procedure 

that requires additional explanation.   
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Pelham, AL 35124 
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Fax: 205-403-6508 
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Chapter 1- Introduction to FLM -ANT 

 

1.1 Overview 

FLM-ANT is a unique, innovative solution designed for creation and management of Access 

Control Lists. FLM-ANT can be configured so that it is remotely controlled from a central 

point or controlled by individual or overlapping supervisors. 

FLM-ANTôs communications system allows FLM-ANT sensors to communicate securely to 

a Central Command and Control (C
3
) facility.  The C

3
 facility is a Windows based software 

application designed to control one or more FLM-ANT sensors and routers.   

 

Key features of the FLM-ANT design include: 

¶    Central Command and Control capability 

¶    Network adaptability 

¶    ACL management 

¶    Merging of multiple ACL lists for filtering management 

¶    Audit logging 
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Chapter 2 - FLM -ANT Setup and Configuration 

2.1  FLM-ANT Sensor Installation & Configuration 

Logging Into the Sensor 

The FLM-ANT sensor is installed with the FreeBSD operating system and the FLM-ANT 

sensor software.  Boot the FLM-ANT sensor with a monitor and a keyboard.  At the login 

prompt, log in as root, and use the passwd command to set a new root password on the FLM-

ANT sensor. Also, log in as admin and set the admin password. 

Configure the Sensor 

1. Configure the hostname.  Change the ñhostnameò entry in /etc/rc.conf . View the 

current hostname by running the command hostname. 

2. Configure the router script.  FLM-ANT sensors can work with any number of different 

translation scripts.  The script is configured by setting the órouter_script_pathô 

configuration value. Factory available options for the configuration value are 

juniper.pl , and no_router .pl .  To set the router script to the default, enter the 

following command on the sensor: pdcontrol config router_script_path=juniper .pl. 

Set the IP address of the router with:  pdcontrol config routeraddress=1.2.3.4 

3. Configure the inputs.  FLM-ANT supports multiple inputs per router. Basically, an input 

means a set of sensor listen interfaces, router interfaces, and settings related to these 

interfaces. The first input is named I0, the second is I1, and so on.  Set the configuration 

value ñinputsò for each group of interfaces to control.   

 pdcontrol config inputs=I0        (for the first only) 

 pdcontrol config inputs=I0,I1     (for the first two) 

4. Configure filter names.  Filter names are set for each input and let ANT know which 

filters on the router should be modified for deployments. 

 pdcontrol config I0.ingress_filter_name = MyIngressFilter 

pdcontrol config I0.egress_filter_name = MyEgressFilter 

5. Configure login and password.  To configure the login name and password to access the 

router, select the appropriate sensor then use the "Edit ->Set Passwords(s) for Device" 

to configure router login information. 

6. Configure IP address, netmask, and default gateway for the control network.  Edit or 

create the ñifconfig_<iface_name>ò entry in /etc/rc.conf.   This entry must be in the 

form:  

  óifconfig_<iface_name>=òinet <ip> netmask <mask>ô  

where ñ<iface_name>ò  is the name of the sensor network interface connected to the 

control network, ñ<ip>ò is the IP address of the sensor on the control network, and 

ñ<mask>ò is the netmask of the control network.  Change the ñdefaultrouterò entry in 

/etc/rc.conf   to reflect the IP address of the network gateway. 

7. Reboot the sensor.  Issue the reboot command on the sensor so that any changes made in 

/etc/rc.conf  take effect. 

Troubleshoot the Sensor Installation & Configuration 

1. Ensure that the physical connections are properly made.  Type ifconfig.  This displays 

the sensorôs interface configurations.  The status of the interfaces should display active. 
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Otherwise, reassess the physical connections, and repeat this procedure until both 

interfaces become active. 

2. Ensure that the IP addresses are properly configured.  Open an existing network or 

create a new network.  Refer to Chapter 5, Section 5.2.  Ping the IP addresses in the 

network to make sure there is communication. 

3. Ensure that the IP addresses of C
3
 stations are configured.  Refer to Section 3.4 for 

further details on configuring access permissions for C
3
 consoles. 

4. Ensure that the sensor communicates with C
3
.  Use Edit -> Check Sensor Connectivity 

from the C
3
 menu to assure that the encrypted communication is working correctly. 

5. Ensure that a new key file is placed in the correct folder(s).  If a new key is created, it 

must be placed in the same folder containing the FLM-ANT application on C
3
 (typically 

in C: \  FLM-ANT \ ) and on any additional C
3
 stations.  Close and reopen C

3
 any time 

the key is changed. See Section 3.4 for a discussion of key files. 

6. Check the log file for further details and error messages.  Select an editor (i.e. vi) and 

open /usr/local/sensor/log.txt  or type tail /usr/local/sensor/log.txt to see the 

most recent log messages. 

2.2 Configure FLM-ANT Sensor from C
3 

As explained in Section 3.3, it is possible to make modifications to the configurations of a 

FLM-ANT sensor by using pdcontrol or by editing /usr/local/sensor/config  directly.  

Alternatively, modifications can also be made through the C
3
 user interface. 

 

1. Select the FLM-ANT sensor that requires configuration modifications. 

2. Select Edit > Sensor Config Page from the C
3
 menu.  The following configuration 

interface appears.  

 

Figure 2.2 ï Sensor Configuration Editor 

3. Refer to Appendix B for a discussion of the meaning and values of the FLM-ANT 
sensor configuration entries. 

1. Manually enter the changes in the pane. 

2. Select OK  to apply the changes or Cancel to abandon them.
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Chapter 3 - Router Setup and Configuration 

3.1 Juniper Router Setup for FLM-ANT 

1. Log into the router as root.  The prompt becomes root@%. 

3. Type cli and press ENTER. The prompt becomes roo t>.  

4. Type configure and press ENTER. The prompt becomes[edit]  followed by root#.  

5. Enable SSH.  This is achieved by typing the following:  

Type: Prompt: 

edit system services [edit system services] 

root# 

set ssh [edit system services] 

root# 

Quit [edit] 

root# 

Set up a user for FLM-ANT.  

 

Type: Prompt: 

edit system login user <loginname> [edit system login user <loginname>] 

root# 

set authentication plain-text-password 

(The password entered must be the same 
as the one saved in the configuration file.  
Refer to Chapter 3, Section 3.4.) 

[edit system login user <loginname>] 

root# 

set class fullaccess [edit system login user <loginname>] 
root# 

Quit [edit] 
root# 

  

Set the router type to Juniper, this is done by changing the value of the ñrouter_script_pathò 

configuration value. Do this by running the command pdcontrol config 

router_script_path=juniper.pl  from the FLM-ANT command line. Refer to Chapter 3, 

Section 3.4 for a discussion of the pdcontrol utility and FLM-ANT configuration entries. 

 3.2 Troubleshoot Router Setup 

1. Verify that the router configurations are correct.  Refer to Chapter 3, Section 3.4 for 

information on editing the configuration.  More specifically, make sure that the 

ñrouter_script_pathò, ñRouterAddressò, ñinputsò, and all input specific entries are 

correct in the configuration file /usr/local/sensor/config . This can also 

viewed from C
3
 by selecting the menu item Edit ->Sensor Config Page with the 

appropriate sensor selected in the Network Layout  pane, or use the pdcontrol utility 

described in Appendix C to view configuration entries. Make sure the router login and 

passwords are set from C
3
.   

2. Ensure that the sensor properly deploys access lists to the router.  Deploy an ACL from 

the sensor to the router.  Refer to Chapter 5, Section 5.5 for further details regarding 

deploying access lists.  Log into the router.  If deployment was successful, the ACL 
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should be located in the routerôs configuration file.  The routerôs configuration can be 

viewed from the FLM-ANT command line by running the command pdcontrol device 

config or from the C
3
 console by selecting the Info->Save Router Config menu item and 

opening the resulting text file in Notepad or a similar text editor. 

Chapter 4 - Monitoring the Network Using C
3 

4.1 Introduction to FLM-ANT C
3 

FLM-ANT uses a óWindows-basedô system to provide network management.  It is referred to 

as the Central Command and Control, or C
3
.  The C

3
 is used to deploy ACLôs to, manipulate 

and monitor each FLM-ANT sensor on the network. 

As depicted in Figure 4.1, the left half of the C
3
 user interface is used for handling network 

attacks.  The right half of this interface contains a layout of the protected network.  

 

Figure 4.1 ï FLM-ANT Central Command & Control Interface 

The following sections describe the menus used to monitor the network and setup the 

monitoring functionality. 

File Menu 

Menu Item Use to: 

New Create a new network layout. 

Open Open a network layout. 

Close Close the current network layout. 

Save Save the current network layout. 

Save As Save the network layout with a different file name. 

Exit Terminate the application. 
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Edit Menu 

Menu Item Use to: 

Insert Root 
Item 

Create a new root-level item in the current 
network layout.   

Insert Child 
Item 

Insert a child-level item into the currently 
selected item in the network layout. 

Edit Item Edit selected item in the network layout. 

Delete Item Delete the current item in the network layout. 

Auto-Add 
Other 
Interfaces 

Automatically add other monitored interfaces of 
the selected sensor. 

Request 
Refresh 

Force the selected sensor to send updated 
information.  (Not normally required) 

Check 
Selected 
Sensor 

Checks communications between C
3
 and the 

selected sensor.  A message will be displayed 
telling the operator if the sensor is UP or 
DOWN. 

Check for 
Down 
Sensors 

Check the communications between all 
sensors.  Display a message if any of the 
sensors are not communicating. 

Sensor 
Config 
Page 

Edit the configuration page for the selected 
FLM-ANT sensor. 

Set 
Passwords 
for Device 

Set the login name, password, and enable 
password for the controlled router/device. 

C3 Config 
Page 

Edit the configuration page for the FLM-ANT 
Central Command and Control. 

Info Menu 

Menu Item Use to: 

Interface 
Stats 

Display router interface statistics of the 
sensor(s) selected in the network tree of the C

3
 

interface.  

ACL 
Counters 

Show hit counts for the current access list(s) in 
the controlled router of the selected sensor(s).   

Save 
Router 
Config 

Allows the C
3
 operator to archive the 

configuration file of the router/device that the 
selected sensor is controlling. 



 

8 

Access List Menu  

Menu Item Use to: 

Find Using 
Text Search 
(inbound) 

Search the inbound access list for a particular 
text pattern. 

Find Using 
Text Search 
(outbound) 

Search the outbound access list for a particular 
text pattern. 

Compare 
Two ACLôs 

Pick two access files and FLM-ANT will 
generate a detailed comparison and summary. 

Deployment 
history of 
highlighted 
sensor 

Load or roll back to a previous ACL 

Load 
selected 
sensorôs 
ACL 

Loads the selected sensorôs access lists into 
the Access List Editor window. 

Load from 
router 
configuration 

Load an access list from a CISCO or Juniper 
configuration file (.txt) into the FLM-ANT 
Access List Editor. 

Simplify 
Ingress 

Simplifies the inbound access list currently 
loaded in the access list editor. 

Simplify 
Egress 

Simplifies the outbound access list currently 
loaded in the access list editor. 

Window Menu  

Menu Item Use to: 

Show Log 
Window 

Display or hide the log-viewer floating window. 

Show 
Graph 
Window 

Display or hide the graph-viewer floating 
window. 

Show 
Access List 

Display or hide the ACL Editor floating window. 

Show Live 
Filter List  

Display or hide the Live Filter List floating 
window. 

Find 
Windows 

Locates and displays all FLM-ANT floating 
windows. 

Use Large 
Icons 

Toggles use of large icons in the network 
layout window on or off. 

Check All Check all of the FLM-ANT units in the network 
layout. 

Uncheck All Uncheck all of the FLM-ANT units in the 
network layout. 
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Help Menu 

Menu Item Use to: 

User 
Manual 

Allows quick and easy access to the FLM-ANT 
user manual. 

C3
 
Help Microsoft HTML Help for FLM-ANT. 

About Version and copyright statement. 

4.2 Network Layout 

Open an Existing Network Layout  

1. Double-click the FLM-ANT icon on the Windows desktop to run C
3
. 

2. Select the network configuration required for monitoring by choosing File > Open from 

the menu.  The Open dialog box appears.  Refer to Figure 5.2. 

 

Figure 4.2 - Open Window for Selecting Network 

 

3. Select the file name of the desired network layout. 

4. Click Open.  The router tree of the file selected is displayed in the pane at the right side 

of the FLM-ANT C
3
 user interface. 
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Figure 4.3 - Sample Network Configuration in C
3
 Interface 

Create a Network Layout 

1. Double-click the FLM-ANT icon on the Windows desktop to run C
3
.   

2. Select File > New to create a network layout file.  The extension of this file is rtr .   

Add Root Item to Network Configuration 

1. Select Edit > Insert Root Item.  The New Item dialog box appears. 

 

Figure 4.4 - Adding a New Root Item to the Network 

2. Type the Router/Device name in the appropriate field. 

3. Indicate if a FLM-ANT sensor is being added by selecting the Router/Device with 

sensor check box. 

4. Enter the Sensor Box IP and Sensor Name if a sensor is added.   

5. If a sensor is added select the input number. The default is 0, which is the first input; 

unless the sensor has been configured to handle multiple interfaces, it should be left as 

zero. 

6. Click OK .  The new item appears as part of the configuration in the router tree pane of 

the C
3
 user interface.
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Add Child Item to FLM-ANT Sensor or Router 

1. Select a FLM-ANT sensor or router from the configuration.   

2. Select Edit > Insert Child Item  to open the New Item dialog box.   

 

Figure 4.5 - Adding a New Item to the Network 

3. Enter the router name in the Router/Device field.  

4. Indicate if a FLM-ANT sensor is being added by selecting the Router/Device sensor 

check box. 

5. Enter the Sensor Box IP and Sensor Name if a sensor is added.   

6. If a sensor is added, select the input number. 

7. Click OK . The new item appears as part of the configuration in the router tree pane of the 

C
3
 user interface. 

Edit a FLM-ANT Sensor or Router 

1. Select the FLM-ANT sensor or router that requires editing. 

2.  Select Edit > Edit Item  from the C
3
 menu.  The Edit Item box appears. 

 

Figure 4.6 - Editing a Network Item 

3. Make the necessary changes to the IP addresses, names, or input number. 

4. Click OK . 

Delete a FLM-ANT Sensor or Router 

1. Select the FLM-ANT sensor or router from the configuration that needs to be deleted. 

2. Select Edit > Delete Item from the C
3
 menu.
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4.3 Monitoring the Network 

In the FLM-ANT C
3
 user interface, select a FLM-ANT sensor. 

 

Figure 4.7 - Selecting the FLM-ANT Sensor 

Network Log 

The log window displays information logged by the FLM-ANT sensor currently selected in 

the network topology window.  Each entry in the log is color coded for ease of use. 

 

Figure 4.8 ï FLM-ANT C
3
 Log Window 

 

To display the log file for the selected item: 

1. Select Window > Show Log Window from the menu.  The log file displays the activities 

executed by the selected FLM-ANT sensor. 

Bandwidth Graph Window 

The bandwidth chart allows the C
3
 operator to view all PNG files in the graph directory.  This 

directory is /usr/local/sensor/bandwidth/.  Any other program that can be configured to create 

PNG files may be used. 
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1. Select Window > Show Graph Window to display the bandwidth graph for the selected 

item.  This graph depicts the total bandwidth coming through the router interface over a 

period of time.  It is useful for determining peak network times and establishing patterns 

of traffic flow.   

2. Using the pull-down menu, select a graph for viewing.  The visible image is 

automatically updated approximately every five minutes.  

 

Figure 4.9 ï FLM-ANT C
3
 Bandwidth Graph Window 

 4.4 Access Control List (ACL) Basics 

In general, access control lists (also referred to as access lists) provide traffic filtering 

capabilities.  This provides security for the network.  Note that in Juniper terminology, access 

lists are called firewall filters. 

 

Access lists filter network traffic by determining whether packets are forwarded or blocked at 

the routerôs interfaces.  In other words, the router examines each packet to determine whether 

to permit or deny the packet, based on the criteria specified in the access list. 
 

FLM-ANT manages two separate access lists per each sensor input: a list applied to inbound 

traffic, and a list applied to outbound traffic.  Each list has its own section in the Access List 

Window.  In the following discussion, reference to any button or action in the Access List 

Window applies to both the inbound and outbound list areas. For example, to save the 

inbound list, click the Save button in the inbound list area of the window, and to save the 

outbound list, click the Save button in the outbound list area of the window. 

 

To obtain the access list window, simply: 

 

1. Select Window from the menu bar. 

2. Select Show Access List, for the following window to appear if it is not already 

displayed. 
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Figure 4.10 - Access List Interface 

 

Notice that the Access Control Entries are color coded, and some may also have a background 

color.  

Access Control entries are color coded by the action the entry performs. 

The deny action is coded in red. 

The permit action is coded in green. 

The shading of the background for an Access Control Entry has the following meaning: 

A red background indicates there is another entry that directly contradicts the highlighted entry. 

A grey background indicates that the entry can be deleted without having any effect on the list. 

This means the highlighted rule you want to apply is already being applied by another rule. 

 

Create an Access Control List 

1. Select Window from the menu bar. 

2. Select Show Access List if the Access List window is not already visible. 

3. Click Append in either the inbound or outbound list areas.  An Add ACL Entry  window 

appears. 
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Figure 4.11 - Create ACL Entry 

4. Select the permission: Deny or Permit. 

5. Select the protocol; IP, ICMP, TCP, UDP, etc.  If TCP or UDP is selected, the port fields 

become functional.  If ICMP is selected, the ICMP options become functional.     

6. Specify source/target IP addresses and masks. 

7. Click OK  when finished. 

8. Control returns to the FLM-ANT C
3
 user interface and appends the new entry to the list. 

Open an Existing Access List 

1. Select Window from the menu bar. 

2. Select Show Access List if the Access List window is not already visible. 

3. Click Open.  The following window appears. 

 

Figure 4.12 - Open Access List 

4. Navigate to the folder containing the access list. 

5. Select the file to open, and click on Open. 

6. Control returns to the FLM-ANT C
3
 interface and displays the list. 

Edit an Access List Entry 

1. Select Window from the menu bar. 

2. Select Show Access List if the Access List window is not already visible. 

3. Create a new list or open an existing access list. 

4. Select an item from the access list to edit. 

5. The Edit Item  button becomes functional. 

6. Click on Edit Item .  The window for editing an access list entry has the same 

functionality as the window used to create an access list entry. 
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7. Double-clicking an access list entry also shows the access list entry editor. 

Delete an Access List Entry 

1. Select Window from the menu bar. 

2. Select Show Access List if the Access List window is not already visible. 

3. Create a new list or open an existing access list. 

4. Select an item from the access list to delete.  To select multiple items from the list, hold 

down the Ctrl  key or the Shift key. 

5. The Delete Item(s) button becomes enabled. 

6. Click on Delete Item(s).   

Save an Access List 

1. Select Window from the menu bar. 

2. Select Show Access List if the Access List window is not already visible. 

3. Create a new list, or open an existing access list. 

4. If an existing access list was opened, click Save, and ignore the following steps. 

5. Click Save As.  The Save As dialog box appears. 

6. Enter a name and navigate to the appropriate folder to save it in. 

7. Click OK . 

4.5 Manipulating Access Control Lists (ACL) 

Merge Access Lists 

Merging is a beneficial tool that combines the entries of two separate access lists and results 

in one combined list.  Note that merging requires files or access lists to already be created and 

saved in a folder. 

 

The manner in which the merge function handles special cases is dependent upon the merge 

option(s) selected.  Details regarding these options are explained below. 

 

1. Select Window from the menu bar. 

2. Select Show Access List from either area of the Access List window. 

3. Open an existing access list. 

4. Click Merge.  The following window appears. 
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Figure 5.13 - Select Access List to Merge with Existing Access List 

5. Select the file to be merged with the current list. 

6. Click Open.  The following Merge Options window appears. 

 

Figure 4.14 - Merge Options Window 

7. The user must select one of the following options: 

i. Automatically choose the best options 

ii. More specific rules have priority over less specific rules 

iii.  Strictly mathematical merge 

If  option i) is selected, then the C
3
 console will try to automatically choose the best options 

for the merge. 

If option ii) is selected, then more specific rules are given priority and the user will be 

presented with a set of four additional options to choose how conflicts will be resolved.  

These options are:  

a. Overlapping conflicting rules use action of original list. 

b. Overlapping conflicting rules use action of new list. 

c. Overlapping conflicting rules should be resolved with the more restrictive rule. 

d. Overlapping conflicting rules should be resolved with the less restrictive rule. 

If option a) is selected, then rules in the original list will take precedence over rules in the 

second input list when there is a conflict.   

If option b) is selected, then rules in the second input list will take precedence, instead, over 

rules in the original list when there is a conflict. 

If option c) is selected, then the more restrictive rule will take precedence when there is a 

conflict between the two input lists, regardless of which list it originates from.   

If option d) is selected, then the less restrictive rule will take precedence when there is a 

conflict, regardless of the list it originates from. 

If option iii) is selected, then the merge will be done as a strictly mathematical set operation.  

An additional choice between the following two options will be presented: 

b. Conflicts should be resolved with the more restrictive rule. 

c. Conflicts should be resolved with the less restrictive rule. 

If a) is selected, then the resulting access list will only permit traffic permitted by each of the 

two input lists.    

If b) is selected, then the resulting access list will only deny traffic denied by each of the two 

input lists. 
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8. There are two check box options which may be enabled: 

a. Use manual confirmation to resolve conflicts. 

b. Log actions to file. 

Option a) allows the user to resolve conflicts as they arise.  When a conflict arises, the user 

will be shown the following dialog: 

 

Figure 4.15 ï Resolve ACL Merging Conflict 

The user may accept the proposed solution by clicking Yes, or Edit  the entry to resolve it 

manually.  The user may also select Yes To All to automatically answer all future conflicts in 

the merge as Yes.  Lastly, the entire merge operation may be cancelled by clicking the 

Cancel Merge button. 

 

Option b) allows the user to log all actions that take place during a merge.  The user is 

prompted to enter a file name and select the folder location.  The file saves a description of all 

actions taken as a text file (.txt). 

Deploy an ACL Using the Access List Interface 

There are two techniques for deploying an ACL; through the Access List interface and the 

Live Filter List Editor .  The primary function of the Access List interface is to generate and 

deploy access lists.  Section 5.6 describes the functionality of the Live Filter List Editor in 

further detail.  The following steps describe deployment through the Access List interface.   

 

Note that deploying an empty list to a FLM-ANT sensor is possible.  Also, all deployed lists 

get displayed in the Live Filter List Editor  associated with the checked sensor. 

 

1. Select Window -> Show Access List from the menu bar if the Access List interface is 

not already visible. 

2. Ensure there are either or both an inbound and outbound access list loaded either by 

adding entries to new list(s) or by opening an existing access list for inbound and/or 

outbound. 

3. Check at least one FLM-ANT sensor check box from the main C
3
 interface.  

4. Check the Deploy check boxes next to the inbound list and/or the outbound list in the 

access lists window to overwrite inbound and outbound lists respectively. At least one of 

these two checkboxes must be checked to deploy. 

5. Click Deploy in the bottom right hand corner of the Access List window to launch the 

selected access list to the checked FLM-ANT sensor(s). 

Loading the Access Lists from the Sensor 

It is possible to load the current access lists deployed at a sensor into the Access List 

interface. 

1. Select the desired sensor in the Network Layout  pane. 

2. Select Access List -> Load selected sensorôs ACL 
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The selected sensorôs inbound and outbound access lists should now be viewable in the 

interface where they can be edited, saved, or deployed to the same or different sensors. 

Cutting and Pasting Access List Items 

It is possible to cut, copy, and paste access list items between the inbound and outbound 

access list areas or from one access list to another.  To copy access list entries, highlight the 

desired entries in either the inbound or outbound area of the interface, then type Control -C. 

To cut access list entries, highlight the desired entries in the inbound or outbound area and 

then type Control -X.  To paste the entries that have been cut or copied first, go to the desired 

access list; you may close the current access list and open another or merely paste the entries 

in a different area of the same list.  Entries may also be pasted from the inbound list into the 

outbound list and vice versa.  Once the desired location for the new entries has been found, 

type Control -V to paste them.  The entries will be appended onto the end of the access list if 

no entries are selected; otherwise the entries will be inserted before the first selected entry in 

the destination list. 

Rolling Back Access Lists 

A sensorôs access lists (inbound and outbound) can be rolled back to a version  

To roll back to another revision select Access List -> Deployment History of Highlighted 

Sensoré from the menu.  The following dialog will appear: 

 

Figure 4.16 ï Roll back to a previous ACL 

Select Ingress and/or Egress and click the Roll Back button.  All of the checked circuits in the 

Network Layout  pane will be rolled back. 

Load a Previous Access List  

Loading a previous ACL is the same as Rollback except press the ñLoad to Editorò button. 
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Comparing Access Lists 

Two access lists can be compared to find differences between them.   To compare access 

lists, select Access List -> Compare Two ACLôs from the menu.  A file selection dialog 

will appear; choose the file containing the first access list file.  A second file selection dialog 

will appear; choose the second access list file.  A browser window will then launch showing 

the differences between the two access lists as an HTML document.     

 

Figure 4.17 ï Access List Comparison Output 

The document will give both a brief summary of the differences as well as a detailed 

enumeration of the lines that differ. To save or print this HTML document from the browser 

window like any other web page using the File -> Save or File -> Print  menu commands. 

Simplifying Access Lists 

The C
3
 console can simplify access lists to remove redundant entries and entries that have no 

effect.  To simplify an access list: 

1. Open the access list in the Access List Editor as either the inbound or outbound access 

list. 

2. Select Access List -> Simplify Inbound or Access List -> Simplify Outbound from the 

menu. 

The access list will be replaced with a simplified version. 

4.6 Live Filter List 

The Live Filter List Editor  interface is a useful tool to quickly edit the current access list of 

a sensor. It allows the operator to add a new ACL entry, delete an existing ACL entry, or add 

a temporary ACL entry, which will expire after a certain period of time. 
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Viewing Live Filter List Editor  

Select Window -> Show Live Filter List  from the menu bar.  The following window 

appears. 

 

Figure 4.18 ï Live Filter List Window 

The window is divided into two areas; the inbound list is shown at the top and the outbound 

list is shown at the bottom.  The buttons are grayed out until a sensor is selected in a network 

layout.  

Add an Entry 

1. Make sure the Live Filter List Editor is visible by selecting Window -> Show Live 

Filter List . 

2. Select a sensor from the network layout pane. 

3. To append an entry to the end of either the inbound or outbound access list of the sensor, 

click the Append button. To insert somewhere else in the existing list, select the item in 

the list that the new entry should immediately proceed by clicking it, then click the Insert 

Above button. 

4. The following window should appear.  Set the appropriate options for the new entry.  



 

22 

 

Figure 4.19 ï Add ACL Entry 

5.  Click OK  to deploy the ACL entry or Cancel to exit without saving the settings.  

Add a Temporary Entry 

1. Make sure the Live Filter List Editor is visible by selecting Window -> Show Live 

Filter List . 

2. Select a sensor from the network layout pane. 

3. Click the Append button. The following window will appear.  

 

Figure 4.20 - Deploy ACL Entry 

5. Set the options for the new item in the same manner as described in Section 5.6. 

5. Enter the required duration of denial in seconds in the Expiration text field.  You can also 

use phrases like ñ1 dayò or ñ3 hours 1 dayò or ñ17:23ò.  The ACL entry will be applied 

for that amount of time. 

Click OK  to deploy the ACL entry or Cancel to exit without saving the settings. 
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Deleting an Entry 

To delete an entry, select an entry in either the inbound or outbound list; then, click the 

corresponding Delete button.  It is possible to delete more than one entry at a time by holding 

down either Shift or Ctrl  while clicking additional entries in the list to select them before 

clicking the Delete button. 
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Chapter 5- FLM -ANT Advanced Configuration 

5.1 Configuring Multiple Inputs 

An input  in FLM-ANT is basically a sensor within a sensor.  Every sensor has at least one 

input, and each input corresponds to one or both of a set of listen interfaces to monitor and a 

set of router interfaces to control.   

A FLM-ANT sensor can have at most sixteen total inputs.  These input interfaces are from 0 

to 15.   Additionally, only five inputs may have a non-empty set of listen interfaces.   

Inputs are named I0, I1, and so forth up to I15.  The inputs in use on a sensor are listed by 

name in the configuration value ñinputsò with commas separating the input names. 

Certain configuration values apply to inputs separately as opposed to the entire sensor.  These 

configuration values are: ñlisten_commentò, ñrouter_commentò, ñlisten_interfaceò, 

ñingress_filter_nameò and ñingress_filter_nameò.  See Section 3.4 and Appendix B for 

more information on configuring these values. 

 Deployments operate on a per input basis.  Access list roll back (see Section 5.5.5) also 

operates on a per input basis.   

If input I0 of a sensor is present in a network layout in the C
3
 console, and no other inputs of 

that sensor are present in the network layout, then it is possible to automatically add all other 

inputs of the sensor as child items of the first input by selecting Edit -> Auto-Add Other 

Interfaces from the menu. 

5.2 Configuring TACACS+ Authentication 

Enabling TACACS+ Authentication 

In the FLM-ANT config file: 

Auth=1  (enables authentication) 

TacServer1=myserver.somedomain.org    ñServer Secret Hereò    3  (this is my first TACACS 

server, server secret, and 3 second timeout) 

TacServer2=backupserver.somedomain.org    ñServer Secret Hereò    10  (this is my second 

TACACS server, server secret, and 10 second timeouté you can have up to 10 TACACS servers) 

 

Additionally, there are several optional configuration values which you can use to control the 

behavior of TACACS+ based authentication.  The entries pdread_cmd, pduser_cmd, and 

pdadmin_cmd can be used to control the required privilege level or command access for each level 

of access to the FLM-ANT sensor 

Configuring Access Levels 

FLM-ANT supports TACACS+ authentication directly.  FLM-ANT uses three different levels of 

access when using TACACS+ which can be configured based on TACACS+ commands or privilege 

levels.   

The three access levels of FLM-ANT are:   

¶ pdread - read access only 

¶ pduser -  controls the editing/deploying of access lists and other similar functions 

¶ pdadmin  - full control over administrative tasks 














